Dynare++ questtion - nonconvergence


I’m trying to run a (fairly large) model on Dynare++. The model file runs fine on standard dynare ( version 4.3.3 used with matlab 2015b) using stoch_simul (se end of attached .mod file), although it takes som time, say 5 minutes. However, when trying to run the file in dynare++ I get the following error message:

Caught dynare exception: dynare3.cpp:172: could not obtain convergence in non-linear solver.

The starting values have been solved using a matlab file, so they should be correct (the resid command in standard dynare gives a bunch of zeros).

When looking at the jnl-file, iterations ends at 500 after running dynare++, so presumably I’ve hit the maximum number of iterations constraint. However, it solved fine using standard dynare. The solver could perhaps be different in dynare (I’ve tried the baseline and solution algorithm number 1) and dynare++, (althugh the initial values are the solution, so it should be able to solve in dynare++ as well, I think).

Does anyone have an idea about what could be the problem?

Many thanks

Andreas Westermark
test_file.mod (792 KB)

which version of Dynare++ are you using? Because I get a lot of errors because you set some parameters twice. Therefore I cannot run the file.
Is there a reason you cannot use Dynare and want to use Dynare++?


Thanks for the reply. I was previously running it on dynare 4.3.3. Now I’ve uploaded a new version of the file that works in 4.4.3 after eliminating parameters declared twice.


test_file.mod (792 KB)

given the size of your problem, Dynare++ cannot solve the steady state at its default tolerance of 10^-13. Your initial values are only accurate up to 10^-7 or so. If you use

it will work. This sets the tolerance to 10^-10