Dynare parallel not working with 4.6.1 version on mac

Dear Houtan,
I’m using MATALAB_2018a on macOS Catalina. Under Dynare 4.5.7 I can run parallel. However, it doesn’t work under 4.6.1 version. Here is my dynare_parallel.txt configuration:

[cluster]
Name = local
Members = n1

[node]
Name = n1
ComputerName = localhost
CPUnbr = 12
DynarePath = /Applications/Dynare/4.6.1/matlab
MatlabOctavePath = /Applications/MATLAB_R2018a.app/bin/matlab

Did you have a look at https://mutschler.eu/dynare/parallel/macos/ ?
Also, you need to @HoutanBastani

Yes, Completely familiar with it and as I said, I was using it under 4.5.7 and even 4.6.0 but not working on 4.6.1! I should say I didn’t install GCC to use ‘use_dll’ but I think it doesn’t have any issue with that!

Then this sounds like a bug that needs to be investigated

I just used a trick! I installed 4.6.1 on my mac pro and 4.6.0 on my macbook pro then copied matlab folder from dynare 4.6.0 and pasted it on 4.6.1. With this I could use parallel with the above configuration (estimated a ramsey policy model). However, there are some problems with it due to different versions!

What is the actual error you get? Also can you run dynare yourmodfile parallel_test?

You can also sent me the mod file, I can try to run it on my mac virtual machine.

There is no error, dynare runs the model, gives mode_check plots but when it should start parallel, it does nothing! when running parallel_test, there is also no error. Everything’s fine in earlier versions but not working on 4.6.1! I can run my model by installing earlier versions and even I estimated a ramsey policy model on 4.6.0 using parallel but not on 4.6.1!

Unfortunately, I am unable to reproduce your error. Using your config file in ~/.dynare (decreasing CPUnbr because I don’t have that many and changing to R2019b) and running dynare ls2003.mod parallel with Dynare 4.6.1, I am unable to reproduce your error. That said, I am running 10.14.6.

Hi, mutschl,
I had used parallel option. Using parallel_test, it is ok.

Testing computer -> localhost <- ...


Check on Local Variable ..... Ok!

Checking Hardware please wait ...
Hardware has 4 Cpu/Cores!
User requires 4 Cpu/Cores!
Check on CPUnbr Variable ..... Ok!



Test for Cluster computation, computer localhost ..... Passed!


AnalyseComputationalEnvironment returned with Error Code: 0

but when I use dynare mymodel parallel, something is wrong

C:\Users\Desktop\test\Dyn_parallel>psexec -accepteula -d -W "C:\Users\Desktop\test\Dyn_parallel" -a 0 -low  matlab -nosplash -nodesktop -minimize  -r "addpath('C:\4.6.1\matlab'), dynareroot = dynare_config(); fParallel(1,1,1,1,'posterior_sampler_core')"  
 
PsExec v2.2 - Execute processes remotely 
Copyright (C) 2001-2016 Mark Russinovich 
Sysinternals - www.sysinternals.com 
 
matlab started with process ID 1280. 
 
C:\Users\Desktop\test\Dyn_parallel>-accepteula -d -W "C:\Users\Desktop\test\Dyn_parallel" -a 1 -low  matlab -nosplash -nodesktop -minimize  -r "addpath('C:\4.6.1\matlab'), dynareroot = dynare_config(); fParallel(2,2,2,1,'posterior_sampler_core')"  
'-accepteula' 不是内部或外部命令,也不是可运行的程序 
或批处理文件。 
 
C:\Users\Desktop\test\Dyn_parallel>ec -accepteula -d -W "C:\Users\Desktop\test\Dyn_parallel" -a 2 -low  matlab -nosplash -nodesktop -minimize  -r "addpath('C:\计量\4.6.1\matlab'), dynareroot = dynare_config(); fParallel(3,3,3,1,'posterior_sampler_core')"  
'ec' 不是内部或外部命令,也不是可运行的程序 
或批处理文件。 
 
C:\Users\Desktop\test\Dyn_parallel>exec -accepteula -d -W "C:\Users\Desktop\test\Dyn_parallel" -a 3 -low  matlab -nosplash -nodesktop -minimize  -r "addpath('C:\计量\4.6.1\matlab'), dynareroot = dynare_config(); fParallel(4,4,4,1,'posterior_sampler_core')"  
'exec' 不是内部或外部命令,也不是可运行的程序 
或批处理文件。 

parallel posterior_sampler_core :

system info.

Win 10
matlab2019a
dynare 4.6.1

The problem has been solved.

Thanks again!

@Wenddy What was the solution?

Sorry, I wasn’t able to work last week, but I am glad that you figured it out. Please let other users know what the issue was, so we can tag this as solved.

I had a similar issue on our university cluster running centOS. For some reason I needed to include my own public ssh key (which is usually in .ssh/id_rsa.pub to the authorized keys in .ssh/authorized_keys.) No clue why…

In case which parallel not working, I had installed PSTools into C:\App\dynare\4.6.1\PSTools

My solution:move PSTools file to another path,e.g. C:\App\PSTools

Then it’s ok!

I suffered the same issue and could not solve the problem by changing the path of pstool. I tried matlab 2019b and 2020a, b, win10, dynare 4.6.1. But when I used the parallel about 8 months ago, it could run without any issue. I was not sure why this issue happened.

Is there any output that may help?

My problems is similar to Wenddy’s. It shows “ec 不是内部或外部命令” and only one MC runs. I find the issue is caused by the chinese-character name of the folder in which my model.mod file is. When I change it into a name in english. The issue is solved.