Dynare++ on Linux (Ubuntu 10.04)


I’m new on dynare but since then I’ve been able to run models using it, and now I tried to run some others using dynare++ but I couldn’t. The prompt from octave said “parse error: syntax error”. What I’m doing wrong? If I understand correctly dynare++ is already installed on dynare 4.1.2 so it should run if it is called from the prompt, or not? Thanks.

by the way, the model I run is

close all;

var Y, C, K, A, H, B;

varexo EPS, NU;

parameters rho, beta, alpha, delta, theta, psi, tau;

alpha = 0.36;
rho = 0.95;
tau = 0.025;
beta = 1/(1.03^0.25);
delta = 0.025;
psi = 0;
theta = 2.95;

CthetaH^(1+psi) = (1-alpha)Y;
exp(B)C/exp(B(1))/C(1)(exp(B(1))alphaY(1)/K(1)+1-delta) = 1;
Y = exp(A)K^alphaH^(1-alpha);
K = exp(B(-1))(Y(-1)-C(-1)) + (1-delta)K(-1);
A = rho
A(-1) + tau
B(-1) + EPS;
B = tauA(-1) + rhoB(-1) + NU;

A = 0;
B = 0;
H = ((1-alpha)/(theta*(1-(delta*alpha)/(1/beta-1+delta))))^(1/(1+psi));
Y = (alpha/(1/beta-1+delta))^(alpha/(1-alpha))*H;
K = alpha/(1/beta-1+delta)Y;
C = Y - delta
vcov = [0.0002 0.00005; 0.00005 0.0001];
order = 7;

then I write

dynare++ model.mod

the it says syntax error


The error message is very clear: it says there is a syntax error at line 1 of your file.

Indeed, Dynare++ does not know about “close all;” which is a MATLAB command completely unknown to Dynare++.

Remove that command and it should work.