Dynare installation on matlab

Hello, I’ve installed Matlab and Dynare but when i type “dynare” on the command window it says that the variable is unrecognizable, I’ve followed the instructions on the Dynare page to add the path and reinstalled Dynare 3 times and it keeps sending me the message. Also I’ve installed 3 different versions but the message keeps appearing. Could someone help me?

What is the exact error message and which exact path did you set how?

The error says “Unrecognized function or variable ‘Dynare’”
I Seth the path first by writing on the command window ```

addpath C:\dynare\4.6.4\matlab

Then I tried through the command window and nothing. I follow this steps:

On the MATLAB Home tab, in the Environment section, click on Set Path
Click Add Folder....  Warning: DO NOT select Add with Subfolders...
Select the matlab subdirectory of your Dynare installation. For example, if you have installed Dynare 4.6.4 in the standard location, select:
Apply the setting by clicking Save button
  1. What is your operating system?
  2. Did you install Dynare to that folder “C:\dynare\4.6.4\matlab”?
  1. Microsoft
  2. Yes!

Then please use the Windows Explorer to verify that there exists a C:\dynare\4.6.4\matlab\dynare.m.

I have the same problem. Whenever I try to use varexo, I got the problem “Unrecognized function or variable ‘varexo’”. I noticed I could not find anything looking at C:\dynare\4.6.4\matlab\dynare.m , but after some disinstallations and installation, I finally find an M File. However, I still get the same error about varexo.
What’s wrong?

Thank you in advance.

@AVR Please provide the full error message.

Unrecognized function or variable ‘varexo’.
Error in FIN (line 4)
varexo e;

That’s it.

That is not the full message, unless you did not call Dynare, but rather a FIN.m-file directly from Matlab.

How am I supposed to call Dynare? Because I am a beginner and I am trying to reproduce a code:

Endogenous variables
var Y
Exogenous variables
varexo e;
parameters alpha, beta, delta, gamma, rho;
alpha = 0.35;
beta = 0.97;
delta = 0.06;
gamma = 0.40;
rho = 0.95;

this is just the beginning of the code, but whenever I try to run it, I got that error. I am pretty sure about the correct installation of Dynare on Matlab, but I do not know if I have to make further steps to make it work.

Thank you again for you time.

How do you run the file, i.e. what are the steps you do?

I run it as I usually do with Matlab (Editor/Run or Evaluate selection).

That is wrong. See 3. Running Dynare — Dynare 4.6.4 documentation
You need to do


Okay, I solved this problem and now it seems to work properly.

Thank you again for your help.