Dynare Installation on Mac

Hi there,

Apologies if this question has already been asked, but I couldn’t find a relevant answer.

I’m using Dynare 4.2.2 on Mac OS X version R2010a.

I’m not sure I have installed Dynare correctly. I am not able to run any of the examples. This is the output I’m getting:

EDU>> dynare example1.mod
??? Undefined function or method ‘dynare’ for input arguments of type ‘char’.

I followed all of the steps on dynare.org/DynareWiki/InstallOnMacOSX so I’m not sure where I could have gone wrong.

Any help is appreciated!


First, you should update to Dynare 4.2.5. If you have Mac OS X 10.6 or higher, there is no reason to use an old (buggy) version of Dynare.

Second, make sure

is in your Matlab path (type

at the Matlab prompt). If it is not there, type

Thanks for the help. Dynare is installed, but now when i try to run example1.mod, i get the following error:

dynare example1.mod

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.2.5).
Starting preprocessing of the model file …
Found 6 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
  • order 2
    ERROR: Can’t open file example1.m for writing

??? Error using ==> dynare at 114
DYNARE: preprocessing failed

Any ideas? Thanks again for the help!!

That is an error that you can get when you do not have write permission in the working directory. To fix this, copy example1.mod to a directory that you create somewhere else (and will thus be able to write to). Then change the working directory of Matlab (or Octave) to this new directory and give it a shot.

It worked. Thanks HoutanBastani and bkjecn!! :smiley:

I have the same problem but with Windows XP installed dynare 4.2.5. I am using Matlab 6.5 and cannot run any of the examples in the directory of “Examples”, although I followed the installation guide, I think.


Did you try running the examples from a different directory?

Also note that Dynare supports Matlab 7.0 or later, so there may be other problems. It is recommended that you upgrade your Matlab version if you want to use Dynare.


Unfortunately, I tried to run the examples from another directory but still I get the same error. The problem may be the Matlab version 6.5. Now I need to get version 7 or higher.

I will let you know when it runs.



Matlab will be faster, but if you want to see if it runs, you could always try Octave for free. www.gnu.org/software/octave/

Hi all, I am working on Mac OS 10.15.3, I have tried installing Dynare 4.6.1 and 4.6 on Google Chrome, Mozilla Firefox, and Safari.

Each time, I am able to initiate the installation process, but at the very end, I get an “Installation Failed” message.

Please advise?


@vinnyb Please post the log-file as instructed above.