Dynare editor issue about parenthesis

I am using dynare 5.1. and matlab2021b. I have an issue with the editor. It does not show the corresponding open parenthesis when I touch the close parenthesis. In other words, when I touch my cursor to close ), it is supposed to highlight the corresponding open paren ( , but it does not. I have uninstalled and reinstalled dynare 5.1. The problem has not gone away.
Any clue?

Which editor are you using? Does your editor recognize that it should do syntax highlighting for mod-files? This has nothing to do with Dynare itself, which does not ship an editor. Also, please do not double-post.

Sorry for double posting. I did not get a notification from you and I thought that my post got lost. I will delete now the other.
I am using matlab2021b editor. My co-author has now reported similar issue in matlab 2022b editor. I just checked that in matlab 2019b editor, matching parenthesis works. This is quiote a new issue. Never had this issue.

Does this happen for all brackets or just for ones where the closing/opening bracket is not shown on the screen anymore?

Thank you for your response. I am afraid I don’t understand your question. What do you mean by all brackets? Let me explain the problem .in terms of an example.
Let us take this assignment:

x=(k-(1-delta)*k(-1) )/zx;.

If I take the cursor to the last closing bracket, the corresponding first opening bracket should lit up. If I touch closing bracket in k(-1). the corresponding ( before -1 should lit up, and so on. This is a convenient feature which helps me to check the consistency of brackets. This feature was present in matlab2019b version but after this it is lost. I have checked with a few other dynare users. They all confirmed this. If I write a matlab code this feature is present. For some reason latest matlab versions do not support mod editor.

BTW, I tried to delete the duplicate post. The system did not let me do this. It says that I have no admin right to delete post. Perhaps you can delete the other post. Sorry about the trouble.

Did you tell Matlab that mod file extensions are supposed to be recognized?

Many thanks jpfeier. You solved my editor problem. It looks like in older versions of matlab this preference was not required. I never did this before for matlab 2019 earlier versions.