Converting from Dynare 3 to Dynare 4


I am trying to run a Dynare file written under Dynare 3.065 under Dynare 4.1. The file works perfectly under Dynare 3; yet under Dynare 4, all I get is the following:

dynare Japan_ML

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.1.0).
Starting preprocessing of the model file …
Found 24 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
  • order 2
    Processing outputs …done
    Preprocessing completed.
    Starting MATLAB/Octave computing.

??? Error: File: Japan_ML.m Line: 221 Column: 23
Unexpected MATLAB operator.

Error in ==> dynare at 132
evalin(‘base’,fname) ;

I checked that I cd’d to the correct directory before I run the file, and Dynare has been added to the path, too. I’ve tried this both with Matlab running on XP and Mac. Other Dynare files are executed without any difficulties (on both platforms), so I’m assuming that my Dynare installation isn’t the issue. Instead I’m thinking that there’s something in the code that Dynare 3 likes, but Dynare 4 doesn’t - but I can’t quite figure out what that is.

Any help would be appreciated,

Japan_ML.mod (9.47 KB)

It seems that Dynare v.4.1 doesn’t like the // syntax to comment out the info lines or it is used improperly. After replacing them with % and excluding the estimation chunk your code works just fine.Japan_ML.mod (9.64 KB)

Wow. You are absolutely right.

Thanks a million! Philipp