I have a problem with the check plots from the check_mode command: The maximum the optimizer finds is not the same as indicated by the posterior (blue line). How can I fix this problem?
By tighter priors? A different optimizer?

Thanks in advance for your help!

Tighter priors will most probably not help as they do not give you more curvature. A different mode-finder should be more successful. Try 8 or 9.

Thanks jpfeifer!

I tried mode_compute=9 and now the MCMC statistics are fine.

Anyway, do you know whether the MCMC draws and the posterior distributions are stored somewhere? I cannot find them in the workspace. I need to plot the posteriors and the Brooks/Gelman statistics for each parameter seperately, i.e. not jointly in this 3x3 subplot array.


In this case it is probably easiest to hack the McMCDiagnostics_core.m file.