Blanchard-Khan Condition is verified

Hi all, I have a problem with this model where I get the following error

There are 15 eigenvalue(s) larger than 1 in modulus
for 15 forward-looking variable(s)

The rank condition is verified.

You did not declare endogenous variables after the estimation/calib_smoother command.
Error in computing likelihood for initial parameter values

ESTIMATION_CHECKS: There was an error in computing the likelihood for initial parameter values.
ESTIMATION_CHECKS: If this is not a problem with the setting of options (check the error message below),
ESTIMATION_CHECKS: you should try using the calibrated version of the model as starting values. To do
ESTIMATION_CHECKS: this, add an empty estimated_params_init-block with use_calibration option immediately before the estimation
ESTIMATION_CHECKS: command (and after the estimated_params-block so that it does not get overwritten):

Error using print_info
Error using print_info
Blanchard & Kahn conditions are not satisfied: indeterminacy.
Error in initial_estimation_checks (line 305)
print_info(info, DynareOptions.noprint, DynareOptions)
Error in dynare_estimation_1 (line 159)
oo_ = initial_estimation_checks(objective_function,xparam1,dataset_,dataset_info,M_,estim_params_,options_,bayestopt_,bounds,oo_);
Error in dynare_estimation (line 118)
Error in Cai_4HW5.driver (line 840)
Error in dynare (line 281)
evalin(‘base’,[fname ‘.driver’]);
Cai_4HW5.mod (20.1 KB)

I really don’t understand what the problem is, since rank condition IS VERIFIED.
Find attached the file

Thank you

You did not provide the data file. Have you tried starting the estimation with the parameter values you used for calibrating the model?

Hi, Thanks a lot for the fast reply.
First of all I attach the data file (sorry for that
SW_Data4HW.xls (271 KB)

I read a previous thread here and addeed:


that I imagine it does exactly what you were saying. However doing this leads to NaN s.d. in posterior distribution of parameters. Is that normal since I included this estimated_params_init(use_calibration); ?

Thank you

It seems your estimation gets stuck in a corner. Are you sure your priors/starting values match the data?