Blanchard Kahn conditions not satisfied


I am trying to perform a Bayesian estimation of a New Keynesian model augmented with sticky wages, habit in consumption, variable capital utilization and investment adjustments costs. The model includes eight shocks and I observe eight variables. However, the classic Blanchard Kahn condition problems arises, as follows:

There are 9 eigenvalue(s) larger than 1 in modulus
for 8 forward-looking variable(s)
The rank conditions ISN’T verified!
Error using print_info (line 40)
Blanchard Kahn conditions are not satisfied: no stable

I have tried desperately to identify the mistake, but so far without success. I have a feeling though that it may come from the three coefficients gammai, gammac and gammak (which are the steady state ratios of investment, consumption and capital, respectively, over output). I don’t understand why but if I set these coefficients to one, the model works. But obviously, it is not acceptable as these coefficients are found using the steady state of the model, and do not equal zero.

Can someone help me? Thanks in advance.

NS5.mod (3.82 KB)

It seems to be a timing problem. What are you doing here:

k(+1) = u(+1)+kbar(+1); kbar(+1) = (1-delta)*kbar+delta*(i+z);

What is kbar and why don’t you define it contemporaneously? Why is the first equation all in expectations?

Thank you for answering. As k (effective capital) and kbar (accumulated capital) are predetermined variables, I thought that setting them as (+1) would not mean expectations. However, you are right, u(+1) should not be in expectations so I change it to u. The problem is still there though.

Effective capital is not predetermined unless capacity utilization has to be chosen one period in advance. Usually, you have

k= u*kbar;

I have decided to get rid of kbar and only keep k, which is accumulated capital: the usual k. I drop the ‘predetermined variable’ command so my k enters the equation with an (-1), as usual in Dynare. Unfortunately, the problem persists.
NS5a.mod (3.78 KB)

I finally found my mistake! A silly typo in the model equations…I am relieved. Thank you jpfeifer for your kindness. Have a nice evening!