/bin/bash: dynare++: command not found (MacOS)

I’m having problems with Matlab. It works pretty well two weeks ago but now I have run again my code and it says that /bin/bash: dynare++: command not found. I have included all the paths as before (see the image). I also downloaded the latest version (5.3) to see what happens, but nothing works. Any help please? Thanks!

Captura de pantalla 2022-11-23 a las 16.46.58

But usually, you don’t call Dynare++ from Matlab. How exactly did you call Dynare++ from within Matlab?

Okay, so let me be more explicit. Sorry for that: I’m creating my .mod file within a script in Matlab (that works perfectly), but then I have to run !dynare++ --per 15 --sim 3 --ss-tol 1e-10 RubenFernandez.mod. With that I should get RubenFernandez.mat, but I don’t get it because dynare++ is not found. That’s what I’ve been taught to do, if there are more efficient/correct ways I’m of course open! Thanks a lot for the fast response.

That’s fine. I am not a Mac user. @wmutschl may be able to help.

1 Like

Thanks a lot. I have edited the question to clarify that I’m a Mac user.

But is Dynare++ also in your system path? You are calling something from the command line. I doubt that the Matlab path will be sufficient in this case.

I’m also including these lines in the script. Is it what you mean?

sorry, but I have no experience with dynare++.

To see whether it is really a problem with PATH, you could open MATLAB from Terminal.app:


and then see whether this helps, see the comment here:

otherwise, I don’t know, did you update something on your machine?


What should I do in /Applications/MATLAB_R2022b.app/bin/matlab? I’ve done what’s written in the link you sent but it doesn’t seem to work D:

Deleted because I solved that particular issue. The original problem still exists. Sorry.

I think this may useful: I get 127 after compiling this.
Captura de pantalla 2022-11-23 a las 19.32.45

Well, I’ve partially solved this: I’ve created a folder dpp/ inside my directory. Then I copied the dynare++ executable in that folder. Then I run !dpp/dynare++ --per 15 --sim 3 --ss-tol 1e-10 RubenFernandez.mod instead of !dynare++ --per 15 --sim 3 --ss-tol 1e-10 RubenFernandez.mod. Now it works. But I don’t like the idea of having to create that dpp/ folder in each directory… Do you have any idea to solve this?

But that clearly shows that dynare++ is not in your system path. Matlab may be able to locate it due to a Matlab path being set. But that does not mean that bash will be able to locate it. That’s why I added @wmutschl because I thought he knows how to tell bash where a file is located.

I agree, indeed. But I’m not being able to solve it…

Did you try anything from macos - Setting PATH environment variable in OSX permanently - Stack Overflow?