Bayesian Estimation problem with error reference to non-existent field

Dear all,

I’m trying to estimate some parameters using the estimation command. However, I encounter an error which I could not find on the forum.
When running the model(after the steady state has been found), Dynare gives me the following error:
You did not declare endogenous variables after the estimation/calib_smoother command.
Reference to non-existent field ‘lb’.
I’ve both tried the original .csv file as well as converting it to a .mat file for the data.
Could anyone explain what I am doing wrong here?
Any help would be much appreciated.

With kind regards,

NCcal.mod (4.2 KB)
DSGE_data.csv (24.0 KB)
EUdataDSGE.mat (10.3 KB)

You are loading a different data file than you uploaded. Regardless, the mat-file will not work, because we do not support Matlab tables and the csv-file as the first column without a name/header.

Thank you for your response Professor Pfeifer.

I accidentally send the wrong .csv and .mat file along, however their contents was identical to the one referred in the code. I removed the first column without the name and have correctly formatted the .mat file however the error still does occur. Is my file still formatted incorrectly or is the estimation setup or command I am using wrong?

with kind regards,

Steven Hoekstra
NCcal.mod (4.2 KB) DSGE_data_no_index.mat (9.9 KB)

As I wrote above

Your mat-file needs to contain each observable as a separate entry. Try

DSGE_data.mat (29.1 KB) NCcal.mod (4.2 KB)

Thank you for your quick response.
I’m new to Matlab, so I did not fully understood what you said previously but I see it now.
The data does get read now, however the Blanchard-Kahn conditions are not met.
I want to use the calibration I’ve found to satisfy the BK conditions for the estimation command as said in the following error:

ESTIMATION_CHECKS: There was an error in computing the likelihood for initial parameter values.
ESTIMATION_CHECKS: If this is not a problem with the setting of options (check the error message below),
ESTIMATION_CHECKS: you should try using the calibrated version of the model as starting values. To do
ESTIMATION_CHECKS: this, add an empty estimated_params_init-block with use_calibration option immediately before the estimation
ESTIMATION_CHECKS: command (and after the estimated_params-block so that it does not get overwritten):

However, when I do so as the error tells me, this doesn’t work.
The manual doesn’t provide me information how to correctly do this as well.
How do I use the calibration values as initial values for the estimation command?
Thank you in advance.

NCcal.mod (4.3 KB)

I see that if I use that option I get the following error:
Log data density [Laplace approximation] is NaN.

Error using chol
Matrix must be positive definite.

I thought that if my calibration satisfied the BK conditions the model would not show explosive behaviour.
I have detrended my data with a one-sided HP filter and further transformed the data by taking the percentage deviation from the steady state, following your paper:
Pfeifer (2013),
Could my problem be due to unforeseen parameter dependence?
Thank you in advance.

When I started changed the estimated parameter to the standard errors of the stochastic terms of my model, the estimation started working.
I much appreciate your help on this topic and will continue working on it.

With kind regards,