Hi everybody!
I’m trying to run the file DH10.mod which is an example of MS-SBVAR, just to have an idea of the output and about how to use the code. Anyway, when I compute “dynare DH10.mod”, I get this error message:

Starting Dynare (version 4.2.1).
Starting preprocessing of the model file …
ERROR: There are 0 equations but 2 endogenous variables!

??? Error using ==> dynare at 126
DYNARE: preprocessing failed

How could I tell the program which equations I’d like to estimate? Any suggestions?

Thank you!

You must first declare the equations like any other model, even if it’s calibrated.
I’d suggest you look at the example files that came with Dynare, such as fs2000.mod. You’ll find these in your C drive in the folder ‘dynare’.

Hope this helps.

I tried to declare some fake equations just to see whether it worked but I got the same error…

post your mod file, maybe I can help. I can’t promise anything, I’ve only been using dynare regularly some weeks ago, and i’ve always worked with calibrated models.

Theoretically, a VAR model doesn’t require any specification of the equations. It’s not like a calibrated model. Anyway, this is the file provided as an example.

Thanks for your availability!
DH10.mod (722 Bytes)

oh yeah didn’t even realise you were talking about a bvar. sorry have no experience what so ever with vars in dynare!


Ms-sbvar currently resides only in the unstable branch. It will be released with the next stable release of Dynare, version 4.3.

You must download the snapshot from the Dynare website to use it. If you have already done so, you need to adjust your matlab path to point to the unstable version of Dynare.

Your path currently points to Dynare 4.2.1 because your output (from the original message in this thread) reads:

[quote]Starting Dynare (version 4.2.1).
Starting preprocessing of the model file …
ERROR: There are 0 equations but 2 endogenous variables![/quote]


I see. Thanks for the explanation! Anyway how could I tell the program to read in the unstable branch?

Go to dynare.org/snapshot/win and download the latest version of the unstable dynare and install it the way you would the stable version. I just tried it and it worked. A new experience. Very interesting.

Thanks! I did not realize that I had installed both dynare 4.2.1 and the unstable version! Now it works.