Where are the results of "mh_conf_sig" stored


I was trying to draw IRFs and their corresponding probability bands. I checked the reference manuel and it says “mh_conf_sig” could able to do that.

So I wrote “mh_conf_sig=0.68” in "estimation ( ) ". But I could’n find the results…

Can anyone help me?

If you have enabled

they should be stored in oo_.PosteriorIRF.dsge.HPDinf/HPDsup

[quote=“jpfeifer”]If you have enabled

they should be stored in oo_.PosteriorIRF.dsge.HPDinf/HPDsup[/quote]

I cannot find the command “bayesian_irf” in the reference manual, can you please show me how to use it?

See dynare.org/manual/index_27.html and search for bayesian_irf. It goes into the estimation command.

I wrote the code as the following

estimation(datafile=data_diff_FHFA,mode_check,mode_compute=5,lik_init=2,mh_replic=0,mh_nblocks=2,presample = 3,mh_jscale=0.20,mh_drop=0.2,mh_conf_sig = 0.68 ,optim=('Display','iter','MaxFunEvals',1500),smoother,bayesian_irf,forecast=20) DLogQl DLogQ DLogC DLogI DLogB LogL Ql I Br Bg C Y;
But still couldn’t find oo_.PosteriorIRF.dsge… Is there anything wrong?

How are you supposed to get Bayesian IRFs when you do not run a MCMC by setting

[quote=“jpfeifer”]How are you supposed to get Bayesian IRFs when you do not run a MCMC by setting

After deleted mh_replic, it is reported that
[list]Error using chol
Matrix must be positive definite.

Error in metropolis_hastings_initialization (line 68)
d = chol(vv);

Error in random_walk_metropolis_hastings (line 62)
ix2, ilogpo2, ModelName, MetropolisFolder, fblck, fline, npar, nblck, nruns, NewFile, MAX_nruns, d ] =

Error in dynare_estimation_1 (line 782)

Error in dynare_estimation (line 89)

Error in realestate_model (line 557)

Error in dynare (line 180)
evalin(‘base’,fname) ;/list]

Does it mean that my model is wrong?

It means that there is still something problematic. Please have a look at the mode_check plots (use the mode_check option). Also, increase the number of function iterations in optim or use a different mode-finder, e.g. mode_compute=9. Lastly, make sure that your observation equations are correct, i.e. that the data and the model variables are correctly linked.

Thanks! It helps a lot!