The error "Reference to non-existent field 'estimation_dll'"

Today, when I run a program which was written a few weeks ago, the dynare prompts an error. In fact, this mod was run successfully, i just wanted to get the results estimated again.
Sadly, i met the problem described as this topic’s subject.
Through checking my mod file, i found the mod file is no problem. And then, i tried to run the examples of dynare package (fs2000.mod).
Unfortunately, it prompts the same error information. Is there anybody to tell me the reason and solution for this problem? thanks…

runtime information:

"

Improvement on iteration 28 = 0.000000717


f at the beginning of new iteration, -1233.8174677131
Predicted improvement: 0.000000022
lambda = 1; f = -1233.8174678
lambda = 1.9332; f = -1233.8174678
lambda = 3.7372; f = -1233.8174677
lambda = 2.5164; f = -1233.8174678
Norm of dx 7.5779e-006

Improvement on iteration 29 = 0.000000075
improvement < crit termination
Objective function at mode: -1233.817468
??? Reference to non-existent field ‘estimation_dll’.

Error in ==> dsge_likelihood at 145
if DynareOptions.estimation_dll

Error in ==> hessian at 25
fx = feval(f,x,varargin{:});

Error in ==> dynare_estimation_1 at 620
hh = reshape(hessian(objective_function,xparam1, …

Error in ==> dynare_estimation at 89
dynare_estimation_1(var_list,dname);

Error in ==> fs2000 at 222
dynare_estimation(var_list_);

Error in ==> dynare at 180
evalin(‘base’,fname) ;

…"
fsdat_simul.m (6.43 KB)
fs2000.mod (3.75 KB)

This sounds a lot like a version conflict. Try uninstalling and then reinstalling Dynare.

thanks for your help. i’ll try your method.

However, if it is a version conflict, there is still a question. why does the mod in the same environment get different result? The dynare version installed on my computer is 4.4.2. i have never installed other versions.

You must have changed something in the meantime. The field estimation_dll is always set in global_initialization.m and is already used during mode-finding, which did not crash. The is what makes it so strange and why I recommend reinstalling. This is a very spurious problem.

I am having the same problem. I have Dynare version 4.4.3. Estimation programs worked fine in February. Today I wanted to verify the results and ran the same *.mod files I did in February, without modification and it doesn’t work. I get the message: Reference to non-existent field ‘estimation_dll’.

I tried uninstalling Dynare and reinstalling as the post suggested, but the problem remains the same.
I would like to mention that the exact same thing has happened on two different Mac computers. I reinstalled dynare on both computers, but the problem remains the same.
Does anyone have any other suggestions, ideas?

Many thanks

PS Subsequent to posting, I installed version 4.4.2 and the problem is solved.

Strange. When reinstalling Dynare, did you clean the Matlab path from Dynare related settings?