Stopping display of irf pictures

hi everybody
is there a trick to prevent display of the irfs or the prior plots in dynare? the ‘nograph’ option does not seem to work.


Just put stoch_simul(…, irf=0,…) and Dynare will not plot the IRF.


hi marcelo
that will not work.
if you set irf=0, then dynare will not only NOT plot the IRF graphs, it will not even compute the IRF functions.
this can be resolved by setting
stoch_simul(irf=20, nograph,…)

if you dont want dynare to plot the priors.
all that you have to do is to go to the code in the dynare folder.
go to plot_priors.m

type in the following

if options_.nograph, return, end;

use nograph in your estimation command.
it should work.


Hi Reuben,

I thought you were asking only for a way for not plotting the IRF. I did not know that actually you wanted only the numbers and not the plots. Sorry about that.