Steady state problems

I have a model that I was able to analytically solve for the steady state. I used this analytical solution in the initial values block. When I run dynare I get the dreaded “STEADY: convergence problems” error message.

I have manually put my steady state values into each equation in the model and they all clear just fine. I used the resid(1) command to see where the problem was and it identified my policy equation and euler type equation as not clearing (these both involve only inflation and the interest rate in the steady state). But once again if I go to these equations in the model and put in the values that I specified in the steady state, the left hand side is equivalent to the right hand side.

Any idea what is going on? I used both of the equations that resid(1) says are not clearing in a simpler model (no capital) and they worked out fine. I have attached the annotated problem file.

Note:

I put the model with no time subscripts into Matlab’s fsolve program and got very similar results to my analytical solution (using my analytical solution as the initial guesses).
canz2_wagestick.mod (5.22 KB)

Dear Jason,

  1. log(beta)=beta-1
    is only an approximation, Dynare will not go for it

  2. from 14) i=1/beta - 1
    from 21) i = -log(beta)

Best

Michel