Steady state mismatch


I have encountered the following problem. I am trying to compute the steady state for a model manually in a separate m-file called modelName_steadystate.m.

When I run the simulation (mod file), I get an error that the steady state was not correctly computed for some of the equations. I can pinpoint the equations that do not hold with the residuals displayed by Dynare. However, when I stop the program inside the steady state file (using keyboard command) and check my equations from the mod file one-by-one, there is no error, the equations with previously significant residuals hold exactly. There is a mismatch between the steady state computed manually and computed by Dynare. I tried using steady, but nothing was changed.

I would appreciate any tip or suggestion from someone who has encountered similar problem. Thank you very much.



P.S. Unfortunately I cannot disclose the model and steady state files.

The only possible explanation is that there is a slight difference between the model that you solve by hand and the one entered in Dynare. Parentheses mistake for example is often the source of such errors.



Thank you very much for the response, also working Sunday evening? :slight_smile:

managed to solve the problem. The problem was in one of the parameters that was computed numerically in the steady state file, there were a few digit differences in computed and originally supplied value. I should have declared it as a variable but did not want to split the mod file for a later switch.