Starting dynare++

I apologize for such a basic question, but how do I start dynare++? I have changed the path of the operating system both on a machine running XP and another one running Vista, but I just simply do not know how to activate the program. I click on Dynare++.exe file, but nothing happens. Do I need to have C++ compiler or something similar?

Since I could not get Dynare++ going, I installed GNU Octave 3.2.3 to try out Dynare 4.1.0 and tried to run example2.mod file that I downloaded from dynare.org. This is what I got:

[quote]GNU Octave, version 3.2.3
Copyright © 2009 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE. For details, type `warranty’.

Octave was configured for “i686-pc-mingw32”.

Additional information about Octave is available at octave.org.

Please contribute if you find this software useful.
For more information, visit octave.org/help-wanted.html

Report bugs to bug@octave.org (but first, please read
octave.org/bugs.html to learn how to write a helpful report).

For information about changes from previous versions, type `news’.

warning: mark_as_command is obsolete and will be removed from a future version o
f Octave
octave-3.2.3.exe:1:C:\Octave\3.2.3_gcc-4.4.0\bin

addpath c:\dynare\4.1.0\matlab
octave-3.2.3.exe:2:C:\Octave\3.2.3_gcc-4.4.0\bin
dynare d:\example2.mod

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.1.0).
Starting preprocessing of the model file …
Found 6 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
  • order 2
    Processing outputs …done
    Preprocessing completed.
    Starting MATLAB/Octave computing.

parse error:

syntax error

d:\example2
^

error: called from:
error: c:\dynare\4.1.0\matlab\dynare.m at line 132, column 1
octave-3.2.3.exe:2:C:\Octave\3.2.3_gcc-4.4.0\bin[/quote]

Any help you can provide me will be hugely appreciated. Needles to say, please make any explanations as simple as possible.

Hi

You should run Dynare from the directory which contains the MOD file:

addpath c:\dynare\4.1.0\matlab
cd d:\
dynare example2.mod

Hello, sorry but I got the same problem for Dynare++. I tried to execute dynare++.exe and nothing happens, and this on two different operating systems, XP and Vista. I added the path as said in the tutorial. Am i missing something?
Thank you

Are you talking about Dynare or Dynare++?

You don’t need to add any path for Dynare++: all you need is to launch the executable from a DOS command prompt (and not from MATLAB or Octave!).

Also, it is normal if nothing is displayed in the screen: Dynare++ puts all its results in files (log file, result file…). See the Dynare++ tutorial.

Also, what version of the Dynare package are you using (Dynare Windows installer comes with Dynare++ bundled)?

Best,

Hi,

I have a similar problem. I have tried to run Dynare ++ (included in version 4.2.2 of Dynare) in the CMD window following the instructions in the tutorial and yet I get an error message… it says " ‘dynare++’ is not recognized as an internal or external command, operable program or batch file" I did run it from the directory where the mod file is.

I have successfully run dynare++ from Matlab some years ago…(when it was not yet distributed with the Dynare). Using the same .mod files that I used then, I now get this error message.

Any idea why I get this error message?

thanks,
Ellen

Dynare++ has to be run from the command line, not from MATLAB.

The point is that Windows does not know where Dynare++ is when you just type “dynare++” on the command line. One solution is to add the directory containing dynare++ (typically c:\dynare\4.2.2\dynare++) to the PATH (search the web for how to do this). An alternative solution is to write the full path when calling Dynare++ (c:\dynare\4.2.2\dynare++\dynare++ .mod)

Best,

Hello,

could you, please, also help me with starting dynare++?
I added the directory containing Dynare++ to the operational path, then typed on the command line: dynare++ example1.mod, and received the following:
“Caught Dynare exception: dynare3.cpp:65: Could not open model file example1.mod”

Where was I wrong?
Regards,
Elena

Please provide a step by step description what you did.