Something wrong in my parameters setting

i write a dynare code and the matlab give the following message,but i can not find where am i wrong,it seems the problem in parameters setting syntax, please help me, thanks in advance

-------------------------------------------------matlab message---------------------------------------------------------
Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.1.2).
Starting preprocessing of the model file …
Found 14 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
  • order 2
    Processing outputs …done
    Preprocessing completed.
    Starting MATLAB/Octave computing.

??? Error: File: C:\Users\Thinkpad\Desktop\dynare\quant and price\monetary.m Line: 131 Column: 1
Missing variable or function.

Error in ==> dynare at 132
evalin(‘base’,fname) ;

-------------------------the mod file--------------------------------------------------------------------------------------------------------------

var c y k R i pai phai omigabar m z v n x r;
varexo eps1 eps2;
parameters h sigma alpha theta delta omiga beta bphai ingta psai l gamma la lb lc kk rhox;
h = 0.65;
sigma = 3.57;
alpha = 0.4;
theta = 11;
delta = 0.024;
omiga = 0.5884;
beta = 0.98;
bphai = 0.7533;
ingta = 0.9728;
psai = 0.60;
l = 2.0;
gamma = 6.16;
la = 0.62;
lb = 1.27;
lc = 0.9238;
kk = 0.66;
rhox = 0.85;
model(linear);
pai=omigapai(-1)/(1+betaomiga^2)+(2-omiga-betaomiga+betaomiga^2)pai(+1)/(1+betaomiga^2)+(1-omiga)(1-betaomiga)phai;
k(+1)=(1-delta)k+deltai;
c=h
c(-1)/(1+h)+c(+1)/(1+h)-(1-h)(R-pai(+1))/((1+h)sigma);
c=h
c(-1)+c(+1)-(1-h)r(+1)/sigma;
y=(1+alpha
(theta-1)/theta)c+(1-alpha)(theta-1)i/theta;
y=z+alpha
n+(1-alpha)k;
omigabar/bphai=(1+ingta
l)psai(omigabar(-1)+pai(-1))-(1+beta)
(1+ingtal)psaipai+(1+ingtal)psaibeta*(omigabar(+1)+pai(+1))+(1-betapsai)(1-psai)(ingtan+sigma*(c-c(-1))/(1-h));
m=sigmac/((1-h)gamma)- sigmahc(-1)/((1-h)gamma)-R/gamma;
m=m(-1)-pai+v;
v=la
v(-1)-lbpai(+1)-lcy+x;
phai=alphaomigabar+(1-alpha)r-z;
n=r+k-omigabar;
z=kk
z(-1)+eps1;
x=rhox
x(-1)+eps2;
end;
steady;
check;
shocks;
var eps1; stderr 0.01;
var eps2; stderr 0.01;
end;
stoch_simul;
monetary.mod (1.21 KB)

Again, the only thing that is wrong is that your first line in the mod-file contains some strange characters “”. Delete them and everything is fine.

thank you very much,i have found the error,usually i use word to read mod file,however it can not show the error as you mentioned above,now i use matlab editor to read the file and it shows clearly,this problem bothered me many times and now i know the solution, thank you in advance.