SOLVED: Installation woes on Ubuntu 20.04 & 21.04

Hi, I had a working set up of Ubuntu 20.04, Dynare and Matlab 2020b. I foolishly updated Matlab to the latest 2020b Update and started getting Dynare: preprocessing failed errors. I upgraded to Ubuntu 21.04 hoping to resolve this with a newer version of Dynare but to no avail. I also tried compiling from source but it kept failing. I also installed older Matlab versions.

I currently have Matlab 2019a Update 9 and Dynare 4.6.3-4 but I always get:

Error using dynare (line 290)
Dynare: preprocessing failed

even on the official example files.

What combination of Dynare and Matlab is guaranteed to work on Ubuntu 21.04?

Many thanks,

Is that the full error message? @sebastien might be able to help. What was the output when trying to compile from source?

That is the full error right now.

After the upgrade to Ubuntu 21.04 with Matlab 2020b Update 7 and adunare upgraded in the process from the repos I was getting missing num_procs. Then I tried compiling from source which finished but then all checks failed.

One of the issues is that Matlab allows downloading only of their latest updates for each version. For 2019a that’s in Sept 2020. Perhaps I should try 2018?

Purging dynare, dynare-matlab, matlab-support and fully reinstalling Matlab 2021a Update 5 and then those packages solved the issue.
Ubuntu LTS is not an ideal long term solution for MATLAB and Dynare. I hope Fedora would be better.

The Dynare package in Ubuntu is directly maintained by the Dynare Team (actually by me), via Debian.

To the best of my knowledge, there is no Fedora package for Dynare, so I doubt it will be better there.

1 Like