Release of Dynare 4.3.1

See the release announcement.

I have used Dynare for some time – but I have an error that I cannot fix. I just installed dynare 4.3.1 on a Windows XP x64 machine. As part of my testing, I have installed dynare 4.3.0 and Matlab 2012a and 2012b – just to try to fix the error. The error is the failure of of the <evalin(‘base’,fname)> command at the end of dynare.m – it happens with three different dynare programs. That is, I consistently receive the <Error using dynare (line 120)> error. The program source code is fine (I have even tried the example1 and example2 programs, plus one additional small program). No end statements are missing. I can insert purposeful errors in the dynare files and trap parser errors easily. But, if the code passes the parser, it always dies on the Matlab evalin command – in both 4.3.0 and 4.3.1, and Matlab 2012a and 2012b. Hints? This is the first (and only) Windows XP x64 machine that I have worked with…(I know, I should update the OS but that is not in my power). Is it simply that dynare 4.3 will not work with Matlab on a Win XP x64 machine? Thank you


What are the names of the .mod files you have tried? My guess is that they overlap with Matlab function names. See [Error: At least one END is missing: the statement may begin).

Also, you should post in this forum by clicking on the NewTopic button, NOT by replying to the announcement.