Ramsey planner with bytecode representation


I am solving my model in the bytecode representation, i.e. I specify the following before the model equations:

    model(block, bytecode, cutoff = 0);

and afterwards, I would use the following steady state algorithm:

    steady(solve_algo = 5, markowitz = 5, maxit=100);

I noticed that in this setup I cannot include planner_objective and ramsey_policy command after the model equations and before the steady state command.

Any advice?


Could you provide me with the files to replicate the issue?


Please notice that line 6 together with line 15 work, whereas line 7 together with line 16 does not


Upload_KN_JME.zip (4.0 KB)

What exactly are you trying to do? The mcp-tag should not be consistent with bytecode. Also, what is the problem you are facing? I am getting

Normalizing the model…
Normalization failed with cutoff, trying symbolic normalization…
ERROR: Could not normalize the model. Variable zlb is not in the maximum cardinality matching.
No normalization could be computed. Aborting.

which seems to be caused by zlb having a unit root.

Thanks for checking. I forgot to remove the mcp-tag and the zlb variables, which are in fact not relevant to my problem. Please find re-attached the (clean) codes in case you can further assist.

All I want to do is to understand why bytecode together with steady(solve_algo = 5) does not work with the Ramsey commands. The reason I am interested in this is because when I expand my model to include additional features, etc. and want to study optimal policy, then only solve_algo=5 works in finding the steady state! Unless you have other suggestions?

Thanks again

Upload_KN_JME.zip (90.7 KB)

In Dynare 5 you would get the correct error message:

The 'block' option is not compatible with 'ramsey_model'/'ramsey_policy'

Thanks! Useful to know that it shouldn’t work