Problems executing Dynare 4.1.3 in under RH ES4

Hi,

I’m working in a Red Hat Enterprise Linux ES release 4 (Nahant Update 8 ) environment.

I configured dynare using the following command:

./configure --prefix=/software/dynare/v4.1.3 --with-boost=/software/Boost/v1.41.0 --with-matlab=/software/matlab_2009b MATLAB_VERSION=R2009b

This worked fine. I then did a “make”, “make html”, “make check” and a “make install”.

Everything seems to work fine except that the output from the “make check” included the following:

Making check in tests
make[1]: Entering directory /software/dynare/dynare-4.1.3/tests' make check-local make[2]: Entering directory/software/dynare/dynare-4.1.3/tests’
error: invalid number of indices (= 0) for 2-dimensional array
error: evaluating argument list element number 1
make[2]: *** [check-octave] Error 1
make[2]: Leaving directory /software/dynare/dynare-4.1.3/tests' make[1]: *** [check-am] Error 2 make[1]: Leaving directory/software/dynare/dynare-4.1.3/tests’
make: *** [check-recursive] Error 1

I was not able to determine a fix or the seriousness of this error so I simply pressed on…

I added /software/dynare/dynare-4.1.3/matlab to my Matlab path and tried to fire up dynare on example1.mod. The log of my attempt in R2009b is as follows:

dynare example1.mod
??? An error occurred while trying to determine whether “dynare_version” is a
function name.

Unexpected error status flag encountered. Resetting to proper state.

I’ve no clue as to why this happened. I made sure that I had the necessary permissions to all files in /software/dynare/dynare-4.1.3/matlab and things looked appropriate.

Then, on a whim, I figured to try the same experiment under matlab R2007b. The log of that attempt is as follows:

dynare example1.mod

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.1.3).
Starting preprocessing of the model file …
Found 6 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
  • order 2
    Processing outputs …done
    Preprocessing completed.

Starting MATLAB/Octave computing.

??? Error using ==> print_info at 36
MJDGGES returns the following error code: 180388626432

Error in ==> stoch_simul at 46
print_info(info, options_.noprint);

Error in ==> example1 at 130
info = stoch_simul(var_list_);

Error in ==> dynare at 132
evalin(‘base’,fname) ;

Now I’m completely mystified. :slight_smile:

I would appreciate it if anyone could enlighten me as to what is happening and what I should do to get around these problems.

Thanks much for any help you can provide! :slight_smile:

Paul