Problem on shared computer

Dear all,

I’ve assigned my students an exercise involving dynare, but have run into the following problem. We have matlab (v, R2008b) installed on a shared computer in our grad student library. I’ve installed dynare (v3) and Fernandez-Villaverde’s examples, and can run them with no problem when I’m logged on.

However, when my students log on and try to run say rbc.mod, they get the error
"Error using ==> dynare at 19
Could not open rbc.mod"

I’ve just been given administrator privileges, and have granted all users read and write access to the ‘examples’ directory, but this hasn’t helped. Are there other issues running dynare on a shared machine?

I’ve had a quick search of this forum and haven’t seen anything like this. Any thoughts or suggestions would be most welcome.

Thanks in advance,

Peter Summers

Dear Peter,

most likely, your students log in with a username different from yours and aren’t in the right directory. In Matlab, you can use
to check the file in the current working directory.




It’s true that they sign in with different usernames, but the directory isn’t an issue. Sorry, I forgot to mention that I gave them specific instructions to change to the proper directory and also run an “addpath” pointing to dynare’s matlab directory.

To be more specific, what I’ve done most recently is that I log on as an administrator, cd to c:\dynare\dynare_v3…\examples, addpath c:\dynare\dynare_v3\matlab, run an example program no problem. I then log out, have a student log on, then I repeat the exact same sequence and get the error message.

The security settings are such that all users should have read & write privileges. Could it be a version 3 thing? I haven’t tried v4.


Hi Peter,

I would be very surprised if that was related to Dynare (version 3 or 4). File handling is very simple. The problem must be at the operating system level.
Can you please confirm that the students can “see” the *.mod file in Matlab by doing the
procedure that I was suggesting in my previous message?
You should also check that the students are able to edit the *.mod file using Matlab editor. This is another operation that isn’t related to Dynare.




I’ve found a solution, and you’re right, it wasn’t a dynare problem. Just in case anyone else has this problem, here’s a description and the fix.

The problem seems to be that the students didn’t have the proper permissions to access the *.mod files. They showed up in the matlab directory, but attempting to open them with the matlab editor resulted in an “access denied” error. The one exception was a file that I’d previously modified and saved (see below).

Anyway, when I right-clicked on a mod file and selected “properties”, then clicked on the “security” tab, I noticed that the group “Users” (ie, my students) didn’t show up on the list. I clicked on the “Advanced” tab, then checked the box that says “Inherit from parent the permission entries that apply to child objects…”. That fixed things.

Oddly, I also discovered that this only applied to the existing example files (these were all the Fernandez-Villaverde examples). At one point I saved a version of rbc.mod with a new name, logged in as a student, and could modify and run the new file with no problem, even though I couldn’t access any of the others.

So for now, at least, problem solved. As always, many thanks for your help.