Problem of Blanchard Kahn conditions are not satisfied: indeterminacy

When I run my code of the paper named the Brexit vote,productivity growth and macroeconomic adjustment in the United State,I get the error message:“Blanchard Kahn conditions aer not satisfied:indeterminacy”. But I dont konw what’s wrong with my code .I hope you can give me some advice. Thank you very much.The paper and my code are attached below.the-brexit-vote-productivity-growth-and-macroeconomic-adjustments-in-the-united-kingdom.pdf (1.1 MBcyx.mod (6.1 KB) )

I think you need to set

predetermined_variables bS;

Thank you very much,Professor Jpfeifer.
I did as you said, and the impulse response diagram could not be obtained. I would like to ask what is the reason, because I have just started to contact Dynare. I encountered this situation for the first time. I hope you can provide me some suggestions. Thank you very much.
stoch_simul:: The simulations conducted for generating IRFs to e_gT were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_gN were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_aT were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_aN were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_s were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_v were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

stoch_simul:: The simulations conducted for generating IRFs to e_mu were explosive.
stoch_simul:: No IRFs will be displayed. Either reduce the shock size,
stoch_simul:: use pruning, or set the approximation order to 1.

Professor Jpfeifer. I have set the approximation order to 1. But The impulse response graphs I got are different from the original paper. Some calibration parameters in the article are not given, they are my own values, but the basic trend of the impulse results are different from the original paper. I feel a bit confused.

Setting order=1 is right. Replicating papers is incredibly hard. Unfortunately, the mistake/problem could be everywhere. In your code, the one of the authors, unstated assumptions, etc.

OK,Thank you very much ,Professor.I’ll try again if it can be solved.

Best!