Problem installing 4.6.0 on MacOS Catalina

I have the same issue:

  • It took under a minute to appear,
  • My Internet connection is fine,
  • Not sure about Xcode tools
  • I just chose default options for install, there weren’t any other that I could see
  • I’ve attached the install log file

install.log (14.5 KB)

Hello everybody.

I had the same problem. I deleted unsuccessfully installed file from Applications and then tried installation with Customized version, I mean without GCC compiler. After this, installation was successfully done! Thus, I guess the problem was in GCC compiler part.

Dear HoutanBastani, could you explain why this problem arose and if I want to install GCC compiler now, what should I do.

Thnx

Likewise all good, thanks

@HoutanBastani I think it has to do with GCC needing to be downloaded.

@pschneider the problem is that the script can’t find git in your PATH.

This should have been installed when you installed XCode on your system and the path should’ve been adjusted accordingly. I do not know why this is not the case. Have you perhaps changed your PATH variable?

@Areg to debug your problem, you need to post the install.log file created in the installation directory after the installation fails.

@HoutanBastani I am facing a similar problem (like @Areg one) in installing. Here, I attach my install.log file. install.log (225.4 KB)

Many thanks.

@Aftab the relevant parts seem to be:

Cloning into ‘/Applications/Dynare/4.6.2/.brew/Library/Taps/homebrew/homebrew-core’…
error: RPC failed; curl 18 transfer closed with outstanding read data remaining
fatal: the remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed
Error: Failure while executing; git clone https://github.com/Homebrew/homebrew-core /Applications/Dynare/4.6.2/.brew/Library/Taps/homebrew/homebrew-core exited with 128.

The first error usually is a problem with the internet connection while the second one is

Hello,
I am facing the same installation problem, however it is not clear to me what I need to do since I don’t know what is GCC compiler…
Thanks for your support.

Elena

@Elena87 Have you tried installing Dynare without the compiler option?

What is the compiler option? Where do I find that?
Elena

I don’t have a Mac. Can you maybe post a screenshot of the installation options for the Customized Installation?

Hope this helps clarify that it is not a customised installation.
Best regards,

Elena

But there should be a way to select the components you want to install, like Dynare++

No there is no choice option when installing the software.

Elena

@HoutanBastani Do you know?

On the Installation Type page select Customise and deselect GCC

1 Like

Hello,

I was running into a similar issue and found that deselecting GCC worked for solving my issue. I believe that I changed PATH so that it cannot find git. How do you remedy this? Thanks!

You should check whether git can found from the command line. If not, the path is not correctly set.

Actually, what should really be done in this case is to manually reinstall the Command Line Tools (CLT), via the Apple website. For some reason, the Dynare installer thinks the CLT are there, while they are not fully installed. This will solve the git problem.