No distribution in the posteriors

Hi everybody,

I’m estimating a new-keynesian model with a production sector of monopolistically competitive firms that combine raw materials, capital, and labor to produce output. I also have importers of consumption and investment goods, and importers of raw materials, all of which have market power. At the same time, households offer differentiated labour in a monopolistically competitive labour market, and thus choose the nominal wage. I have paremeters of calvo that indicate the percent of firms/households that can’t adjust their prices/wages at each moment t.
When I try to estimate these parameters, I get the following posteriors (see attached file). Epsq and epsw, the parameters of price stickiness associated to output prices and wages, do not have a posterior distribution, but only a value, which coincides with the initial value I give to them in the estimated_params block. I have beta_pdf distributions for these parameters, but when I try to use an uniform between 0 and 1, the estimation fails. (I’m using the Metropolis-Hastings algortithm)

Any ideas on how to procede or what might be deriving these results?

Thank you very much,

Rafael
posteriors_mymodel.pdf (7.73 KB)

If your model implementation is correct, this indicates problems with the jumping distribution of the MCMC. Try a different mode_compute. Also try using the option

or

which is available in Dynare 4.4.

Hi Prof. Pfeifer,

Thank you very much for your reply. I tried both the prior_variance and the identity_matrix for the MCMC, and neither worked out. I also tried with different mode_computes and the estimation is even worse. I tried using the option mode_check and this is what I get (see attached file) . I am a bit confused with the red points, does anybody know what do they mean? Is this a signal of something wrong in my model or identification problems in the parameters? I would really appreciate if someone could guide me on the next step to tackle these problems.

Thanks again,

Rafael
mode_check_epsilons.pdf (9.05 KB)

I need the mod-file.