Newrat's code not working (Dynare 4)


I have been trying to use newrat’s code during the estimation with the new Dynare snapshot (mode_compute = 5), but I am encountering the following problem:

[code]??? Input argument “number_of_observations” is undefined.

Error in ==> DsgeLikelihood_hh at 166
no_missing_data_flag = (number_of_observations==gend*nobs);

Error in ==> mr_hessian at 50
[f0, ff0]=feval(func,x,varargin{:});

Error in ==> newrat at 63
[dum, gg, htol0, igg, hhg]=mr_hessian(func_hh,x,flagit,htol,varargin{:});

Error in ==> dynare_estimation_1 at 419
[xparam1,hh,gg,fval,invhess] =

Error in ==> dynare_estimation at 62

Error in ==> model_07_exp at 581

Error in ==> dynare at 102
evalin(‘base’,fname) ;[/code]

Anyone has a suggestion on how to overcome this?



Hi again. I noticed that the same mod file with mode_compute = 5 works perfectly on a Unix cluster. Could this be a problem with the way Dynare was compiled on my Mac?


The problem was solved by copying the content of DSGElikelihood_hh.m that worked on the server and substitute it in the same file on my mac. For some reason when I installed version 4.0.4, this particular file was not updated. I had tried recompiling dynare and doing matlab_build, but that didn’t help either.