Mdbnomics for Octave


I have been trying to test mdbnomics with Octave (using a branch “octave_fix” from the mdbnomics repository) since I wanted to spread the use of mdbnomics to colleagues who do not have Matlab licenses.

Unfortunately I have not been successful in replicating the behavior I get using Matlab. It seems that something goes wrong with webread.m when restful_service is invoked.
Are you aware of such issues, or in your opinion Octave should be fully compatible with mdbnomics?

Many thanks.

@MichelJuillard may be able to answer that.

Thanks @giovanma75, we weren’t aware of the problem. We are going to investigate and hopefully fix it

All the best

Thanks a lot. Just some background info to could help you.

  1. I used the octave-fix branch; [I checked the master branch as well with no success]
  2. I am using Octave 7.2.0;
  3. in the function initialize_mdbnomics (), line 53 I had to comment the logical OR statement i.e. I have
    if (isoctave && octave_ver_less_than(‘6’)) %|| matlab_ver_less_than(‘8.5’)
    because matlab_ver_less_than was causing an error;
  4. the error message I receive is:
    error: Could not fetch data from URL:
    ea19sitc/M.EA19.IMP.TRD_VAL_SCA.EA19.TOTAL&offset=0 because:
    error: called from
    fetch_series_page at line 49 column 5
    iter_series_info at line 42 column 19
    fetch_series_by_api_link at line 51 column 64
    fetch_series at line 119 column 4
    fetchdata_octave at line 70 column 33

Thanks again

@giovanma75 I have fixed the compatibility of mdbnomics.m for Octave v7.2 I couldn’t check Octave v6.4.0 that is required to work with Dynare on Windows. Please, tell me if there is a problem.

@MichelJuillard thank you!
I tried with the new master branch. Still, it crashes on line 93 of webread.m returning in ME.message ’ restful_service: SSL connect error’
I tried webread for reading other webpages -not dbnomics related- from Octave, and it seems to work.

I wonder if there are some extra Octave configurations to be done beforehand to let Octave accessing dbnomics…

Which version of Octave are you using? Which OS?
Can you try simply

I am using GNU Octave Version: 7.2.0 (hg id: 6c1e310b2230) on Windows 10 .
I get the same error:
error: restful_service: SSL connect error
error: called from
webread at line 93 column 14

When I do that on my Windows 10 machine with Octave 7.2 , I get

ans = {
  "v22": {
    "href": "/v22"
  "latest": {
    "href": "/latest"

Thanks @jpfeifer that is what is expected. @giovanma75, I suspect a weird interaction between Octave webread and the proxy at your office… Can you try from home?

Ok issue resolved. At home it works ( although it populates the command window with output, I guess that using semicolon it is not enough in Octave to suppress output to be written in the command window, I need to learn Octave, I guess).
On monday I will have IT people check what is going wrong from the office.
Many thanks @MichelJuillard and @jpfeifer for your help and your work, and sorry for wasting some of your time!