Installing Dynare 4.2.0 on Ubuntu 10.10

I run MATLAB R2011a.

When I do: apt-get install dynare-matlab I get the following error (everything else appears to run fine)

…/…/…/…/dynare++/sylv/cc/SylvParams.cpp:136: error: ‘mxCreateScalarDouble’ was not declared in this scope
make[1]: *** [libdynare___a-SylvParams.o] Error 1
make[1]: Leaving directory `/usr/src/dynare-matlab/mex/build/matlab/libdynare++'
make: *** [all-recursive] Error 1
dpkg: error processing dynare-matlab (–configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any thoughts?


Is it possible that I specified the MATLAB directory or the user account incorrect? If so, is there a way for me to give them different values? I tried to remove and the install Dynare again but that screen prompting MATLAB directory and user account never reappeared.

The problem comes from a function that has been removed in the latest MATLAB (R2011a). Dynare 4.2.0 cannot be compiled out-of-the box with that MATLAB version. This will be fixed in the next Dynare release (4.2.1).

In the meantime, as a workaround, you can manually edit SylvParams.cpp, and replace “mxCreateScalarDouble” by “mxCreateDoubleScalar”. This will fix your problem.


Great! Thanks!