Impossible to find the Steady state

I am having serious problem with finding the steady state. I tried different suggestions I found here on the firum still I have the same error message (rror using print_info (line 74)
Impossible to find the steady state. Either the model doesn’t have a steady state, there are an infinity of steady
states, or the guess values are too far from the solution).

Any suggestion on how to solve this problem will be very appreciated.
Many thanks,
replicationmodel.mod (6.59 KB)

Use the unstable version with

Then use model_diagnostics and fix the collinearity problem.

Thank you so much for your response. However, I am not able to find any command for the model_diagnostic. Is there a command for ? .
Because I still have the error message
(Error in steady (line 92)
print_info(info,options_.noprint, options_);
Error in replicationmodel (line 366)
Error in dynare (line 180)
evalin(‘base’,fname) :wink:
Is it what I need for the model diagnostic…
Many thanks again…

here is another message I am getting. is this what you mean by model diagnostics?
Error in check (line 76)
print_info(info, 0, options);
Error in replicationmodel (line 365)
oo_.dr.eigval = check(M_,options_,oo_);
Error in dynare (line 180)

Thank you again

See the manual. After you run Dynare, just type

Thank you jpfeifer. you are very helpful…