"Impossible to find steady state" despite feeding solved analytic steady state values

Hi all,

I’m trying to estimate a NK model with both price and wage stickiness. I’ve solved for the analytical steady state by hand, and found steady-state values for all the (17) endogenous variables. However, when I estimate the model, it still throws up the dreaded “impossible to find…” error.

I ran the dynare file with the “resid” command, and it shows that the residuals using the initvals are all really small (all e-05 or smaller), which I interpret to mean that I’m feeding values close to the steady state. The estimated residuals are all very small (the largest is 0.002, the others are e-04 or smaller). And still, “steady” does not seem to be able to find a steady state. I tried increasing maxit to 1000, and still no luck.

Can someone guide me as to what I’m doing wrong? Many thanks!
Dynare_Procyclical_Markups.mod (4.2 KB)

Your residuals are still bigger than the tolerance Dynare allows. You can decrease it by setting


before calling steady

Thank you, @jpfeifer!

In my case, I ended up doing the following: (1) I increased the precision of those parameters of the model which are related to 6 decimal places; for example, beta and target interest rate are related, so I increased the precision with which these are specified, and (b) I used a steady_state_model block instead of feeding the calculated values as initvals.

This took care of the problem. However, it is good to know that the tolerance can be controlled to address such issues. Very grateful for the time and effort you spend on this forum. You are truly the Nick Cox of the Dynare world!

1 Like