Help with Dynare

**Dear all

I use Dynare to solve an open economy DSGE model. But, it always shows the fllowing**

THEORETICAL MOMENTS

VARIABLE MEAN STD. DEV. VARIANCE
s 1.0000 0.7531 0.5672
rk NaN NaN NaN
w NaN NaN NaN
rd 1.0273 0.1651 0.0272
nfa NaN NaN NaN
k NaN NaN NaN
kbar NaN NaN NaN
u NaN NaN NaN
q NaN NaN NaN
h NaN NaN NaN
y NaN NaN NaN
c NaN NaN NaN
i NaN NaN NaN
psiz NaN NaN NaN
nu NaN NaN NaN
omegabar NaN NaN NaN
fd NaN NaN NaN
pbar 1.0000 0.0000 0.0000
fx NaN NaN NaN
pxbar 1.0000 0.0000 0.0000
fw NaN NaN NaN
wbar 1.0000 0.0000 0.0000
fmc NaN NaN NaN
fmi NaN NaN NaN
fmx NaN NaN NaN
pmcbar 1.0000 0.0000 0.0000
pmibar 1.0000 0.0000 0.0000
pmxbar 1.0000 0.0000 0.0000
pi 1.0070 0.1035 0.0107
pic 1.0070 0.1138 0.0129
pii 1.0070 0.1138 0.0129
pix 1.0070 0.1362 0.0186
pimc 1.0070 0.1838 0.0338
pimi 1.0070 0.1838 0.0338
pimx 1.0070 0.1838 0.0338
gammac NaN NaN NaN
gammai NaN NaN NaN
gammax NaN NaN NaN
gammamc NaN NaN NaN
gammami NaN NaN NaN
gammamx NaN NaN NaN
sbar NaN NaN NaN
ystar 1.3742 0.1587 0.0252
pistar 1.0070 0.1155 0.0133
rstar 0.6849 0.2861 0.0819
pitarget 1.0070 0.1163 0.0135
muz 1.0100 0.1166 0.0136
up 1.0000 0.1155 0.0133
zetac 1.0000 0.1155 0.0133
zetah 1.0000 0.1155 0.0133
g 1.0899 0.1258 0.0158
sigma 0.2318 0.0268 0.0007
zstar 1.0000 0.1155 0.0133
varepsilon 1.0000 0.1155 0.0133
xie 0.9544 0.1102 0.0121

All endogenous are constant or non stationary, not displaying correlations and auto-correlations

I can not find where is the problem. The steady state has been correctly solvesd. I need some help.Thanks

Hmm, I am having a similar problem and can’t figure out a solution. Any tips?

Please provide the mod-files

mysecond_steadystate_core.m (2.14 KB)
mysecond_steadystate.m (4.08 KB)
mysecond.mod (19.3 KB)

Your model has a unit root. Thus, some of the unconditional moments you are trying to compute do not exists and are consequentially reported as NaN.

Thank you very much! But how can I solve the probem of unit root ? Hoping for your suggestion ! Thank you!

Check your model whether there is an economic reason for the unit root. If not, find the error in your equations. You can run

to get more information and the source of the problem.

I have considered the stochastic trends in tecnology and the price, I am considering why there is still having a unit root in my model. Can you give me some more suggestions ? Tkank you very much!

[quote=“jpfeifer”]Check your model whether there is an economic reason for the unit root. If not, find the error in your equations. You can run

to get more information and the source of the problem.[/quote]

Thank you! I will have a try.