Help:eigenvalues is close to 0/0

hi, i’m a beginner of dynare, i have log-linearize the model by hand, and put the linearization model into Dynare mod. The Error message is

dynare floatlinear4.mod

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.2.5).
Starting preprocessing of the model file …
Found 13 equation(s).
Evaluating expressions…done
Computing static model derivatives:

  • order 1
    Computing dynamic model derivatives:
  • order 1
    Processing outputs …done
    Preprocessing completed.
    Starting MATLAB/Octave computing.

STEADY-STATE RESULTS:

p 0
y 0
pf 0
r 0
s 0
x 0
c 0
w 0
pm 0
l 0
m 0
mc 0
b 0
??? Error using ==> print_info at 52
One of the eigenvalues is close to 0/0 (the absolute value of numerator and denominator is smaller than 1e-6)

Error in ==> stoch_simul at 71
print_info(info, options_.noprint);

Error in ==> floatlinear4 at 221
info = stoch_simul(var_list_);

Error in ==> dynare at 120
evalin(‘base’,fname) ;

what’s the problem? it is because of the model structure or the parameter? ths verymuch
floatlinear4.mod (1.33 KB)

You have a collinearity issue. If you type

you get:

[quote]model_diagnostic: the Jacobian of the static model is singular
there is 1 colinear relationships between the variables and the equations
Colinear variables:
p
y
s
x
c
w
pm
l
m
b
Colinear equations
3 4 5
[/quote]

Looks like an issue with Walras’ Law

Dear Jpfeifer,
much much appreciate!!

best
bingnian