Help:Blanchard Kahn conditions are not satisfied

Hi, everyone. I am a rookie in dynare and recently I got the following message from my dynare code for my model:

Error using print_info (line 42)
Blanchard Kahn conditions are not satisfied: no stable equilibrium
Error in stoch_simul (line 98)
print_info(info, options_.noprint, options_);
Error in backup (line 339)
info = stoch_simul(var_list_);
Error in dynare (line 180)
evalin(‘base’,fname) ;

The attachment is my dynare code.

Thanks in advance for any help provided on the dynare forum!
backup.mod (3.42 KB)

Hi, everyone.

I changed the code a little bit but the problem still not solved, I wonder how to make my code work.

I would appreciate any help provided on the forum!
backup2.mod (3.32 KB)

Hi, I run the model_diagnostics command and got the following message:

The following endogenous variables aren’t present at the current period in the model:

I wonder how I can solve this problem? Since I don’t think my equations are wrong…

I really hope someone could help with this. Thanks

This implies your timing for b is wrong, which explains why the BK conditions are not satisfied

Hi, dear jpfeifer:

Thanks for your reply

Once again, I made som changes to my code and now the BK conditions are satisfied but the rank condition is not staisfied

Some of the eigenvalues are exploded…

I think my problem may come come from my domestic interest rate equation since my model is very similar to the original Carlstrom and Fuerst(1997) model

The only 2 major differences from the original CF model are: (I try to derive a very simple small open economy model with the carlstrom Fuerst financial frictions setting)

  1. I add the domestic real interest rate equation (as shown in my mod file) and add the variable b into consumer’s budget constraint. b is the amount of external debt.

  2. the utility function is slightly changed, I assume consumers consumer both domestic goods and foreign goods, so the utility function has the form:

U(cd,cf,1-h) = (1/1-eps)*(cd^theta * cf^(1-theta))^(1-eps) + log (1-h)

which is just a very tiny adjustment to the simple utility function presented in the CF model…so I don’t really think my problem comes from here.

the attachment’s my modified code

Thanks in advance for any help again!
backup(modified).mod (3.67 KB)

I just realize it is just a timing problem again!

My problem solved, thanks!!!