Error using dynare (line 174) DYNARE: preprocessing failed

Hello all,

I am attempting to run a bit of code and am receiving the following error message:

Starting Dynare (version 4.4.3).
Starting preprocessing of the model file …
ERROR: main_us_annotated.mod: line 349, cols 1-0: syntax error, unexpected $end

Error using dynare (line 174)
DYNARE: preprocessing failed


What is odd to me is that this program ends before line 349. So, the error message is referencing a nonexistent line of code. I’ve tried combing through the code looking for issues but am not really finding anything. That being said, I am very new to Dynare and this code was written by other people (I am just replicating something).

I have attached the code (as a .mod file) in question. I’ve tried attaching the data as well but Excel extensions are not allowed, apparently.

I would really appreciate some feedback here. Thanks all!
main_us_annotated.mod (9.95 KB)

This is not Dynare code. It’s simple Matlab code. You cannot run Dynare on this file. Execute it as a Matlab function