Error: Unexpected ';'

Hi everyone

Running my .mod file, Dynare tells me all the time the following error message:

Starting preprocessing of the model file …
ERROR: new.mod:93.82: syntax error, unexpected ‘;’

??? Error using ==> dynare at 126
DYNARE: preprocessing failed

I think there must be any syntax error, but I don’t find it. I would highly appreciate if you could help me on this.

best regards,

new.mod (3.77 KB)

There is a missing closing bracket in the Taylor rule.

Hi jpfeifer

Thanks a lot, now it works. However, Dynare tells me now:

Warning: Matrix is singular to working precision.

This I think is strange as the author of the attached paper used the very same model but was able to estimate the model, therefore I wanted to ask you if you have any idea why this happens?

The only thing I changed actually is that I use for the three foreign variables yw, iw and piw for each of them a seperate AR(1) process rather than a VAR(2) model, but I think that should not generate the problem, does it?

Otherwise I tried with the same parameter values as him once with the priors and once with the estimated model parameters stated in his paper.

Does someone has any idea where the problem is and how to proceed?

best regard

OutputGap_StefanLeist.pdf (793 KB)
new.mod (3.84 KB)

Hi everyone

Ok, this time I found the error by myself. Seems to work now. So if anyone is interested in getting a Beltran Draper DSGE Model (small open economy with consumption habits), you can have a look at this .mod file. Should work now.

best regards,

new.mod (3.89 KB)