Error message when I run sample files

Hi Michel and all

I installed dynare 4.0(scilab version) and try to run sample files.

There is no Scilab version of Dynare version 4.0.

Can you check which version you are really using and which file did you download from the server?



Yes. The version is 3.02.(I downloaded
What causes the problem?

With Scilab version 4.0, it is necessary to add the following steps to redo the binaries. At the Scilab prompt, execute the followin commands:

cd c:\dynare\scilab

It may be necessary to reload Scilab for the modifications to take effect.



Thank you so much.
I did as you suggest. The result is as follows.

Warning :redefining function: uplib

Warning: Error in file dynarescilabasset_fff.sci :
"endfunction is missing"
file ignored

!–error 4
undefined variable : fl
at line 12 of function getsave called by :
line 87 of function genlib called by :
line 3 of function uplib called by :

I checked uplib.sci.

function uplib()

There might be no problem.

Dear Koji,

I think you aren’t in the right directory when you did uplib(). You must do

cd c:\dynare\scilab

It is also possible that you copied other files into c:\dynare\scilab. If that is the case, it is best to erase all files in directory c:\dynare\scilab and start the installation again.

Kind regards


I confirmed that the directory is right. I tried re-install many times.
(And there is no other file in c:\dynare\scilab .
I still have the same problem.

There might be something wrong in irf.sci or stoch_simul.sci?

The 11the line of irf.sci is as follows.


When I delete this line, graphics are shown with no error message.
Is this method correct?

Dear Koji,

thank you for reporting the problem. I will try to correct it as soon as possible

Kind regards