Error message - gensylv.dll

When I try to use the stoch_simul command in examples from “Practicing Dynare” or the User’s Guide I get to following error message:

??? Invalid MEX-file ‘C:\dynare_v3\matlab\gensylv.dll’: The specified
procedure could not be found.

If I change order to 1 everything works fine. Have I not installed Dyanre correctly? If so, how can I fix it?



the gensylv module is used for Sylvester equation, which is only needed in the second order.

If Matlab whines about an invalid mex-file, then probably the Matlab dynamic loader couldn’t load the dll. There might be quite a few reasons for this. A very different version of Matlab, or a confusion of paths and different versions of Matlab on one machine, or you miss some library (other dll) which gensylv.dll is linked to (or the version of a library to which gensylv.dll is linked to is not compatible). I created gensylv module, and I am sure (provided that the library was linked properly by Michel), that it should depend only on standard Win32 libraries and then on lapack/blas from Matlab distribution. Try to use DependecyWalker (google and download) on gensylv.dll and see if you miss any dependencies. Try to fix any confusion in windows PATHs if multiple versions of Matlab on one machine. And, try to compile and link the library on your own for your Matlab environment.


Ondra K.

if it is of interest, I have generated that error in R2008a, then gone back to R2007a and got the same code to run. So it may be a latest version of Matlab issue

I also receive the same error message when I run dynare using either of the two newest versions of Matlab: versions 2007b or 2008a. Earlier versions of Matlab work fine. Is there any more information on potential fixes?


A workaround is probably to get the version of gensylv which is distributed with Dynare v4, and which works for recent versions of Matlab.

The file is mex/2007b/gensylv.mexw32 in Dynare v4 snapshot. Remove your old gensylv.dll and replace it by that file.

Another solution is simply to switch to Dynare v4.


I have the same problem with version R2007b
At work I do not have the rights to install programs so I cannot install the tools to get version 4. Is there any other way to get the file or somebody could send it?