Error in fs2000 example file in dynare 5.2

I am getting the following error while trying to run the fs2000 example file of dynare 5.2. Could you help in rectifying the same.
fs2000.mod (4.1 KB)
fsdat.m (4.5 KB)

Error: File: DsgeSmoother.m Line: 481 Column: 13
“mm” previously appeared to be used as a function or command, conflicting with its use here as the name of a variable.
A possible cause of this error is that you forgot to initialize the variable, or you have initialized it implicitly using load or eval.

Error in dynare_estimation_1 (line 601)
[atT,innov,measurement_error,updated_variables,ys,trend_coeff,aK,T,R,P,PK,decomp,Trend,state_uncertainty,M_,oo_,bayestopt_] =

Error in dynare_estimation (line 118)

Error in fs2001.driver (line 269)

Error in dynare (line 281)
evalin(‘base’,[fname ‘.driver’]);

It seems you did not upload the file you tried to run.

It seems you did not upload the correct file you tried to run.

The .mod file is taken directly from the examples folder of dynare 5.2. The error shows up sometimes with dynare version 5.2 and not with a lower version. The error shown is as follows
An error occurred while trying to determine whether “dseries” is a function name.

Error in fs2000.driver (line 24)

Error in dynare (line 281)
evalin(‘base’,[fname ‘.driver’]);

Caused by:
Cannot redefine class ‘dseries’ without a call to ‘clear classes’.

fs2000.mod (4.1 KB)
fsdat_simul.m (6.4 KB)

I ran the files you posted in Dynare 4.5.7 in MATALB R2020a. They worked like a charm.

This is caused by a path conflict. You must have an older Dynare version still present in the search path.

Thank you. Yes in the lower version the result have come smoothly.

I’ll look into it. I face this same problem many times