Error in dyn_first_order_solver


I am trying to run a bunch of mod files on a MacOS 10.13 running Matlab 2014a and Dynare 4.4.3. I got the following error messages on every mod file I tried, including the examples that come with Dynare distributions, so I think it maybe a more complex compatibility issue rather than a coding error.

The following error message is generated running the attached mod (a replication of Frank Schorfheide (2000) “Loss function-based evaluation of DSGE models”, Journal of Applied Econometrics, 15, 645-67 by Michel Juillard, February 2004), but for every code I tried they look all the same.

Index exceeds matrix dimensions.

Error in dyn_first_order_solver (line 248)
temp = temp(nd-nsfwrd+1:nd-nba)-1-DynareOptions.qz_criterium;

Error in stochastic_solvers (line 217)
[dr,info] = dyn_first_order_solver(jacobia_,M_,dr,options_,task);

Error in resol (line 137)
[dr,info] = stochastic_solvers(dr,check_flag,M,options,oo);

Error in stoch_simul (line 88)
[oo_.dr,info,M_,options_,oo_] = resol(0,M_,options_,oo_);

Error in fs2000ns (line 209)
info = stoch_simul(var_list_);

The error comes after verifying that the rank condition is satisfied.

I tried the same mods on a Windows computer with the same Dynare distribution and everything works fine but I would like to solve the issue also on Mac. I tried to reinstall Dynare but the same thing happens with version 4.5.3.

Does anybody have a hint on why this maybe happening?

Thank you very much for your help!

fs2000ns.mod (2.8 KB)

Did you check that there is no path conflict, i.e. paths to older versions set? Try cleaning the Matlab path and then resetting the path to Dynare’s Matlab folder

Hi! Thanks a lot for the suggestion but unfortunately it did not work. I restored the default Matlab path and readded the Dynare matlab folder. Still the same issue.