Dynare on Mac OS Lion


I have tried to install Dynare on Mac OS Lion and ran into a couple of issues: First I tried this using matlab 2010b and 2011a, same issue;

running build_dynare I get this result:

checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… ./install-sh -c -d
checking for gawk… no
checking for mawk… no
checking for nawk… no
checking for awk… awk
checking whether make sets $(MAKE)… no
checking build system type… i386-apple-darwin11.1.0
checking host system type… i386-apple-darwin11.1.0
checking for MATLAB prefix… /Applications/MATLAB_R2011a.app
checking whether to enable MATLAB support… yes
checking for MATLAB version… 2011a
checking for MEX-file suffix… mexmaci64
setting MEX-file suffix to .mexmaci64
checking for MATLAB machine architecture… maci64
checking for a sed that does not truncate output… /usr/bin/sed
checking for options to compile MEX for MATLAB… ok
checking for gcc… no
checking for cc… no
checking for cl.exe… no
configure: error: no acceptable C compiler found in $PATH
See `config.log’ for more details.
/bin/bash: make: command not found
cp: src/mex/matlab/*: No such file or directory

Note: I have Xcode 4.1 installed and there is a c compiler on my mac. Any suggestions how I can get this to work? Thanks.


Following the instructions found here: dynare.org/DynareWiki/InstallOnMacOSX I have been able to build the Dynare mex files and run dynare on OS X Lion.

Are you certain you have installed the latest version of Xcode (4.1.1)? The reason I ask is that when you run the configure script, it does not find make:

, which would obviously not allow you to build the mex files. If you open Terminal (Applications->Utilities->Terminal.app) and type make --version at the command prompt, what’s the output? If you then type gcc --version, what’s the output? Please also do the same in Matlab (i.e., open Matlab and at the prompt type: system('make --version') and system('gcc --version')) and send me the output.

Also, please post /Applications/Dynare/4.2.1/src/mex/build/matlab/config.log


I got it to work. For some reason it worked after un- and reinstalling Xcode.