Dynare function sss.m and irfsss.m

Hi, I am trying to run the replication code for Dynare working paper Cho et al. (2020)

It seems like they use sss.m and irfsss.m to produce IRFs from stochastic steady-state. But for some reason MATLAB gives me an error in using those functions (attached below).

irfsss.m (1.8 KB)
sss.m (1.4 KB)

Anyone knows how to get these functions in corrected version that do not give errors? They look like that they were made by Dynare team. But I cannot find those functions in my Dynare directory.


What is the error message you are getting? The files look like they will only be compatible with Dynare 4.5.7.

Thank you @jpfeifer for your reply. The error that I got was about the number of input argument in using simult_.m in sss.m.

Not enough input arguments.
Error in simult_ (line 37)
iter = size(ex_,1);
Error in sss (line 44)
y       = simult_(temps,dr,ex1,iorder); 
Error in calvo.driver (line 396)
oo_.stochastic_steady_state = sss(oo_.dr, irfburninlength, options_.order);
Error in dynare (line 281)
evalin('base',[fname '.driver']); 

I just tried with Dynare 4.5.7 but this time what I get is

Error using dseries
Method 'dseries' is not defined for class 'dseries' or is removed from MATLAB's search path.
Error in initialize_dseries_toolbox (line 66)
Error in dynare_config (line 252)
Error in dynare (line 63)
dynareroot = dynare_config; 

But I get the same error for other .mod files as well when using Dynare 4.5.7.

The dseries error happens when you have conflicting paths set in Matlab to different Dynare version. You may want to use restoredefaultpath in Matlab.

@jpfeifer Yes, this was indeed the issue. Thank you so much!