Dynare 4.4.3 on 18.04

I am trying to build Dynare 4.4.3 on ubuntu 18.04 from source and am getting a build error. Is it possible to build dynare 4.4.3 on 18.04?

my configure line:
./configure --with-matlab=../MATLAB/R2017a/ MATLAB_VERSION=9.0 --prefix=.../dynare/4.4.3/ --disable-octave


collect2: error: ld returned 1 exit status
Makefile:383: recipe for target 'mjdgges.mexa64' failed
make[2]: *** [mjdgges.mexa64] Error 1
make[2]: Leaving directory '/work/dynare/dynare-4.4.3/mex/build/matlab/mjdgges'
Makefile:394: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/work/dynare/dynare-4.4.3/mex/build/matlab'
Makefile:409: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

Any assistance is appreciated, even if its just that will not work on 18.04/


@sebastien This seems like a question for you.

@jrose Could you retry giving absolute paths to the configure script rather than relative ones?

Also note that MATLAB R2017a corresponds to version 9.1.

Hi @sebastien

I tried again with absolute paths and changed the MATLAB_VERSION to 9.1…still no joy and I get the same error.

Ok, then I need more technical information. Can you copy/paste more of the error message? (it looks like it is truncated). Ideally I would need the whole build log, possibly by email (sebastien@dynare.org).

Note that one possibility is that your MATLAB version is too recent for that (rather old) version of Dynare, but I can’t confirm without more details.

After looking at the logs, I confirm that the problem comes from the version of MATLAB, which is too recent.

Dynare 4.4.3 was released in 2014, and is only compatible with MATLAB R2013b (or older, down to R2006b).