Deleting redundant equation changes IRFs

Hi together,

this question is related to ["Convergency obtained" - but not true): It is the same model/file, I only substituted some of the specifications of the utility function into the model, i.e. instead of uc and an additional equation that states uc=1/c I directly inserted everywhere 1/c.

I have one specification left ucc, but if I delete that variable I get different results (to the power of -4). As an example, the tax rate (row 7 in oo_.endo_simul) in the second period goes from 0.240000014217568 (with ucc) to 0.239998670891546 (without ucc), i.e. it changes also qualitatively relative to its steady state 0.24. Now, is that a numerical error I have to live with or is there something wrong?

Thanks

Ps. I also checked just setting ucc=1 insteady of ucc=-1/c^2 but it is the same result - again, ucc is not in the model otherwise! When I used stoch_simul it correctly puts the coefficient 0 in front of the states.
adam_dynare.mod (3.41 KB)

You are currently using Dynare’s default tolerance for steady state computations. It is in the order 1e-6. Thus, differences in this order point to numerical inaccuracies. But when I run you file, I get a singularity warning. This points to a deeper issue.