Codes fine but Dynare installation produces error


I created a mod file to replicate some irfs from a recent paper, however, i keep getting the error below when i run the codes on my laptop. My codes are fine because they run well, generating moments and irfs, when i run the code on my office PC. I tried reinstalling Dynare but that does not fix the problem. I even confirmed that the mex file cited below was in the specified folder. Any help or advice will be greatly appreciated.

??? Invalid MEX-file
The specified module could not be found.

Error in ==> dr1 at 327
[ss,tt,w,sdim,dr.eigval,info1] =

Error in ==> resol at 128
[dr,info,M_,options_,oo_] = dr1(dr,check_flag,M_,options_,oo_);

Error in ==> check at 45
[dr, info] = resol(oo_.steady_state,1);

Error in ==> gali08 at 98

Error in ==> dynare at 132
evalin(‘base’,fname) ;

What are the versions of Matlab on your office computer and your laptop?
What are the operating systems?



Thanks Mike. I was using one of those portable Matlab Software which does not require a complete installation, which resulted in the errors. Problem is now fixed.