Can't get Dynare to work in Octave


I’ve just downloaded Octave to use with Dynare on my MacOS machine, as my Matlab license was attached to my previous institution. I can’t seem to get it to work.

I’ve tried Octave versions 4.4.1 and 6.1.0 and Dynare versions 4.5.7, 4.6.1, 4.6.2, and 4.6.3. Across multiple combinations, I seem to generate either an error or warning with the text, “/Applications/Dynare/4.5.7/matlab/…/mex/octave/: No such file or directory”

Have I set up something wrong? Which versions of Octave and Dynare should I be using? I keep getting warnings telling me to use previous versions of Octave, though bizarrely Dynare 4.6.3 asks to use Octave 4.4.1, while Dynare 4.6.1 asks me to use a later version. Is this reversion deliberate?

Thanks for your help!


First note that it’s really Octave 4.4.1 that you should use with Dynare 4.6.3. The version displayed in 4.6.1 was a bug.

Also note that it’s the version from that you have to install. It will not work with another version (for example from homebrew).

The error message that you get should not happen with 4.6.3.

However I’ve just tried to do the whole installation on macOS Big Sur, with Octave 4.4.1 and Dynare 4.6.3, and I got a crash when running Dynare. I don’t know if this is specific to Big Sur, or also happens on older releases.

Unfortunately, we do not have a lot of ressources to maintain our macOS package, and the situation is not fully satisfactory. Hopefully this will improve for the 4.7 release.

Hi Sebastien,

Thank you for your response. I am running Catalina, and it doesn’t work with that build of Octave. No worries… I should be getting a PC from my employer soon, so I can try with that. And I’ll try with 4.7 when it is available.

Thanks again