Building 4.4.1 from source on RHEL

For Dynare 4.3.*, I used the command ./configure --with-matlab=/opt/matlab --with-boost=/opt/boost-1.42 MATLAB_VERSION=7.10 and everything went fine, but when I try this command with Dynare 4.4.1, it gives me the error “configure: error: Your Octave is too old, please upgrade to version 3.6 at least.
configure: error: ./configure failed for mex/build/octave”. However, the command “octave --version” says that I have version 3.6.4. Is version 3.8 required now or is it just supported?

I also tried ./configure with the addition of “–disable-octave” (which works), but when I run make I get the error (sorry for the wall of text):

make[2]: Entering directory /lcl/mq/home/dynare/dynare-4.4.1/mex/build/matlab/libdynare++' g++ -DPACKAGE_NAME=\"dynare\" -DPACKAGE_TARNAME=\"dynare\" -DPACKAGE_VERSION=\"4.4.1\" -DPACKAGE_STRING=\"dynare\ 4.4.1\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"dynare\" -DVERSION=\"4.4.1\" -DHAVE_MATLAB=1 -DHAVE_PTHREAD=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBM=1 -DHAVE_LIBZ=1 -D_GNU_SOURCE -DNDEBUG -DMATLAB_VERSION=0x0710 -DMATLAB_MEX_FILE -DMEXEXT=\".mexa64\" -I. -I/opt/matlab/extern/include -I../../../sources -I../../../../dynare++/src -I../../../../dynare++/kord -I../../../../dynare++/tl/cc -I../../../../dynare++/utils/cc -I../../../../dynare++/sylv/cc -I../../../../dynare++/integ/cc -I../../../sources -fPIC -pthread -g -O2 -fno-omit-frame-pointer -Wall -Wno-parentheses -MT libdynare___a-faa_di_bruno.o -MD -MP -MF .deps/libdynare___a-faa_di_bruno.Tpo -c -o libdynare___a-faa_di_bruno.otest -f ‘…/…/…/…/dynare++/kord/faa_di_bruno.cpp’ || echo ‘./’../../../../dynare++/kord/faa_di_bruno.cpp In file included from ./tensor.hweb:53, from ./gs_tensor.hweb:24, from ./t_container.hweb:53, from ./stack_container.hweb:87, from ./faa_di_bruno.hweb:18, from ./faa_di_bruno.cweb:10: ./twod_matrix.hweb:29:20: error: matio.h: No such file or directory ./twod_matrix.hweb:60: error: 'mat_t' has not been declared ./twod_matrix.hweb:106: error: 'mat_t' has not been declared ./t_container.hweb:283: error: 'mat_t' has not been declared make[2]: *** [libdynare___a-faa_di_bruno.o] Error 1 make[2]: Leaving directory/lcl/mq/home/dynare/dynare-4.4.1/mex/build/matlab/libdynare++'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/lcl/mq/home/dynare/dynare-4.4.1/mex/build/matlab’
make: *** [all-recursive] Error 1

A quick test confirmed that the install probably didn’t work because a .mod file which works with dynare 4.3.3 doesn’t work using dynare 4.4.1.

I don’t really need octave support… but could you please advise on what the issue might be and what I can do about it? I’ll be happy to provide you with more information

-Eric Till

You’re missing (or the configure script is not finding) libmatio:

If it’s not installed, install it. If it is installed and is not being found, pass the --with-matio=/path/to/matio option to the configure script.