Adding growth rate of existing varible

I worked with Smet and Wouter (2007) code that I modified a little.

First, I ran the code without following “dlab” variable.
Then, I only added growth rate of labor like “dlab=lab-lab(-1)” into old code.

I thought this would not change existing results, because new variable doesnot seem to influence old ones in structure.

However, it changed posterior estimates a little bit and conditional variance decompostion results very much.

How can it be possible?

I wish some dynare users can help me.

Thank you in advance for reply.

** My code is attached below.
sw_robustcheck_new_neo_dlab_n.mod (6.16 KB)

What you describe cannot be possible if your estimation has converged to the ergodic mean. Did you use sufficient draws and monitor convergence?

Thank you, Mr. Pfeifer.

However, by Brooks and Gelman plots, estimation results seem to converge, and the number of posterior subdraws is 1,000, which, I think, is sufficient number.

Still, this problem is mystery to me.

Then please provide two zip-files with the mod-file and the dataset to replicate the two different estimation cases.

Thank you again for your kind interests, Mr. Pfeifer.

I uploade my codes and data files.

Baseline code is one that has no dlab variable, while modified code is one that has dlab variable.

In addition, I uploade conditional variance decompostion results under two different codes.

As I mentioned, two codes are nothing different except that one has no dlab variable, while the other has dlab variable.
Conditional variance decomposition results.pdf (162 KB)
modified code.zip (6.09 KB)
baseline code.zip (6.05 KB)

This has to do with the random number generator used in the MCMC and thus signals a convergence issue. The problem here comes from: github.com/DynareTeam/dynare/issues/1048
It should go away with more draws.

Dear, Mr. Pfeifer.

I want to check this issue by using more posterior subdraws, which are used for computing irf, variance decompostion, etc.

Default subdraw number is 1,000 in dynare, so I added “sub_draws = 30000” in estimation option.

But, after run, the number of subdraws is still 1,000.

How can I increase the number of subdraws?

By the way, what is the logic of generating subdraws?
Last 1,000 draws or equally mixed 1,000 draws, or etc.?

Thank you always for your kind reply.

How do you figure that sub_draws is not correctly updated?
The draws are taken randomly from the posterior.

From “file name_posterior_draw1~3” files in metropolis folder, sum of the number of each file’'s row is 1,000, even though I added “sub_draws = 30000” in estimation option.

Is it right way to figure out the number of sub_draws?

Actually yes, but I cannot replicate your issue. could you please try running the code in a different, empty folder and see what happens?